Ticket #1106 (closed task: invalid)

Opened 3 years ago

Last modified 3 years ago

Is the license is OSI compliant?

Reported by: https://www.google.com/accounts/o8/id?id=AItOawkPb0RtPyicSdU7pLcv1UrX-yCh-YjkOwU Owned by: desai
Priority: major Milestone: Bcfg2 1.3.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc:

Description

 http://en.wikipedia.org/wiki/Bcfg2 says the license is BSD, but in fact it is something different - http://trac.mcs.anl.gov/projects/bcfg2/browser/COPYRIGHT

Is the used license approved by OSI?

Attachments

Change History

Changed 3 years ago by solj

  • status changed from new to closed
  • type changed from defect to task
  • resolution set to invalid

Changed 3 years ago by https://www.google.com/accounts/o8/id?id=AItOawkPb0RtPyicSdU7pLcv1UrX-yCh-YjkOwU

  • status changed from closed to reopened
  • resolution invalid deleted

Modified 4 clause BSD licenses can be non-OSI compliant. Why not to take the text of BSD license and explicitly mention the parts that were modified inside the COPYRIGHT.txt?

I can immediately see that the following points are not present in current license text:

2. Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.
3. All advertising materials mentioning features or use of this software
   must display the following acknowledgement:
   This product includes software developed by the <organization>.
4. Neither the name of the <organization> nor the
   names of its contributors may be used to endorse or promote products
   derived from this software without specific prior written permission.

It seems that the MIT license matches to the current text more appropriately.

Changed 3 years ago by solj

  • status changed from reopened to closed
  • resolution set to invalid

I don't think we'll worry about this too much since it is not preventing inclusion in any major distributions.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

Add/Change #1106 (Is the license is OSI compliant?)

Author


E-mail address and user name can be saved in the Preferences.


Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
 
Note: See TracTickets for help on using tickets.