Ticket #19 (closed enhancement: fixed)

Opened 14 years ago

Last modified 14 years ago

CN control process leaks file descriptors

Reported by: iskra Owned by: iskra
Priority: minor Milestone:
Component: ZeptoOS Version:
Keywords: Cc:

Description

When launching the fuse clients and such, the CN "control" process leaks internal file descriptors. It's not a big deal because the fuse client is trusted, and we do properly close the descriptors for the user app, but it would still be nice to fix. The problem is that system() call used to launch fuse and such does not make it easy. Should we implement a custom system()?

Change History

comment:1 Changed 14 years ago by anonymous

  • Type changed from defect to enhancement

comment:2 Changed 14 years ago by iskra

  • Status changed from new to assigned

comment:3 Changed 14 years ago by iskra

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed using fcntl(FD_CLOEXEC).

Note: See TracTickets for help on using tickets.