Custom Query (894 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (55 - 57 of 894)

Ticket Owner Reporter Resolution Summary
#855 desai somekool <[email protected]…> wontfix release a patch update for 0.9.6
Description

0.9.6 still deserve a maintenance release.

on top of the two patches I uploaded on ticket #846

I will upload to this ticket my modified RPM spec file and 2 more patches.

#916 desai https://www.google.com/accounts/o8/id?id=AItOawmAKncTPlNx89GjuQyu9LtzyN37kpWeSCw fixed r6010 breaks client
Description

after upgrading from r5992 to r6019, the client exists with

Unknown failure
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/Bcfg2/Proxy.py", line 57, in __call__
    return _Method.__call__(self, *args)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib/pymodules/python2.6/Bcfg2/Proxy.py", line 266, in request
    self.send_content(h, request_body)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1349, in send_content
    connection.endheaders()
  File "/usr/lib/python2.6/httplib.py", line 904, in endheaders
    self._send_output()
  File "/usr/lib/python2.6/httplib.py", line 776, in _send_output
    self.send(msg)
  File "/usr/lib/python2.6/httplib.py", line 735, in send
    self.connect()
  File "/usr/lib/pymodules/python2.6/Bcfg2/Proxy.py", line 153, in connect
    self._connect_py26ssl()
  File "/usr/lib/pymodules/python2.6/Bcfg2/Proxy.py", line 188, in _connect_py26ssl
    self.sock.connect((self.host, self.port))
  File "/usr/lib/python2.6/ssl.py", line 307, in connect
    self.ca_certs)
TypeError: sslwrap() argument 3 must be string or None, not bool
Failed to download probes from bcfg2
Server Failure

This is caused by the keyfile argument to SSLSocket() on line 186 of Proxy.py being False instead of None when no client certificates are used.

Reverting r6010 fixes the problem.

#445 desai lueningh fixed python-lxml vs. lxml
Description

It looks like Redhat/Fedora? ship with 'python-lxml', while the "official" LXML packages are just named 'lxml'. Since Suse doesn't include a package, I need this spec file patch to install cleanly:

--- bcfg2.spec.orig     2007-05-29 15:40:07.000000000 -0500
+++ bcfg2.spec  2007-05-29 15:36:46.000000000 -0500
@@ -19,7 +19,11 @@
 BuildArch:        noarch
 
 BuildRequires:    python-devel
+%if "%{_vendor}" == "redhat"
 Requires:         python-lxml >= 0.9
+%else
+Requires:         lxml >= 0.9
+%endif
 
 %description
 Bcfg2 helps system administrators produce a consistent, reproducible,

Note: See TracQuery for help on using queries.