Custom Query (894 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (19 - 21 of 894)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
Ticket Owner Reporter Resolution Summary
#744 desai strauss wontfix Packages.py determines version to install using Yum instead of its own metadata
Description

See summary.

This causes installation of newer versions than expected if the client has newer packages available.

#745 desai strauss fixed Packages.py fails to process any dependencies
Description

For example:

>>> loop.plugins['Packages'].complete(m, ['ssh'], debug=True)
(set(['ssh']), set(['ssh']), 'yum')
>>> loop.plugins['Packages'].complete(m, ['bash'], debug=True)
Package(s) ['bash'] provide(s) bash
Using package bash for requirement bash
(set(['bash']), set([]), 'yum')

#749 desai strauss fixed Yum removal failure
Description

Backtrace goodness. This is against r5466 on RHEL 5.

Bulk erase failed with errors:
Attempting individual erase for each package.
YUMng.Remove() failed
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Bcfg2/Client/Frame.py", line 320, in Remove
    tool.Remove(extras)
  File "/usr/lib/python2.4/site-packages/Bcfg2/Client/Tools/YUMng.py", line 341, in RemovePackages
    if inst.haskey('epoch'):
AttributeError: 'lxml.etree._Element' object has no attribute 'haskey'
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
Note: See TracQuery for help on using queries.