Modify

Ticket #1009 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

bcfg2-server sends data that is not properly encoded

Reported by: Michael Laß <bevan@…> Owned by: desai
Priority: major Milestone: Bcfg2 1.2.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc:

Description

When trying to deploy files with special chars in it (like german umlauts (ä, ö, ü, ..)) I get tracebacks on the client. I have attached two files containing the output of bcfg2-client.

bcfg2-error-w-lxml.log: Output when python-lxml is installed

bcfg2-error-wo-lxml.log: Output when python-lxml is not installed

The file which should be deployed is UTF-8 encoded. Server and client have set 'encoding = utf-8' in their configurations.

I'm using bcfg2-server 1.1.1 on a Debian lenny machine. On client side I can reproduce the problem with Debian lenny, squeeze and Ubuntu natty without python-lxml installed, but only on Ubuntu natty with python-lxml installed. So versions of python-lxml older than 2.3 seem to avoid this problem somehow...

I have also attached a patch for the client which solves the problem. But I think this is only a workaround and the real problem is on server side because the XML data should be encoded correctly before it is sent to the client.

Attachments

bcfg2-error-w-lxml.log (559 bytes) - added by Michael Laß <bevan@…> 10 years ago.
Output when python-lxml installed
bcfg2-error-wo-lxml.log (609 bytes) - added by Michael Laß <bevan@…> 10 years ago.
Output when python-lxml not installed
bcfg2-fix-encoding.patch (524 bytes) - added by Michael Laß <bevan@…> 10 years ago.
Patch for bcfg2-client to avoidd the problem

Change History

Changed 10 years ago by Michael Laß <bevan@…>

Output when python-lxml installed

Changed 10 years ago by Michael Laß <bevan@…>

Output when python-lxml not installed

Changed 10 years ago by Michael Laß <bevan@…>

Patch for bcfg2-client to avoidd the problem

comment:1 Changed 10 years ago by solj

  • Status changed from new to closed
  • Resolution set to fixed

Holger Weiß fixed this in 661405723930c64ca20fbb8191b6772cef919ea6.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.