Modify

Ticket #1015 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Interactive client repeatedly asks whether to modify 'important' files

Reported by: https://profiles.google.com/holger.weiss Owned by: solj
Priority: major Milestone: Bcfg2 1.2.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc: sol.jerome@…

Description

"bcfg2 -I" gets confused when 'important' files are modified: the diff/prompt pairs are shown repeatedly (all in all: four times), and the prompt must be confirmed twice.

Attachments

Change History

comment:1 follow-up: ↓ 3 Changed 10 years ago by solj

I am unable to reproduce this behavior in the latest code:

# bcfg2 -vqIb base-gentoo                                                                                         
Running probe current-kernel
Probe current-kernel has result:
2.6.36-gentoo-r8
Running probe groups
Probe groups has result:
group:gentoo
group:linux
group:amd64
Loaded tool drivers:
 Action    POSIX     Portage   RcUpdate  VCS


Phase: initial
Correct entries:        4
Incorrect entries:      7
Total managed entries:  11
Unmanaged entries:      239

--- 

+++ 

@@ -1,1 +1,2 @@

+test
 
Install Path /test.txt: (y/N): 

Phase: final
Correct entries:        4
Incorrect entries:      1
 Path:/test.txt                  
Total managed entries:  5
Unmanaged entries:      239

# bcfg2 -vqIb base-gentoo
Running probe current-kernel
Probe current-kernel has result:
2.6.36-gentoo-r8
Running probe groups
Probe groups has result:
group:gentoo
group:linux
group:amd64
Loaded tool drivers:
 Action    POSIX     Portage   RcUpdate  VCS


Phase: initial
Correct entries:        4
Incorrect entries:      7
Total managed entries:  11
Unmanaged entries:      239

--- 

+++ 

@@ -1,1 +1,2 @@

+test
 
Install Path /test.txt: (y/N): y
Installing file /test.txt
The Following Bundles have been modified:
 base-gentoo 


Phase: final
Correct entries:        5
Incorrect entries:      0
Total managed entries:  6
Unmanaged entries:      239

comment:2 Changed 10 years ago by solj

  • Cc sol.jerome@… added

comment:3 in reply to: ↑ 1 Changed 10 years ago by https://profiles.google.com/holger.weiss

Replying to solj:

I am unable to reproduce this behavior in the latest code:

# bcfg2 -vqIb base-gentoo

[...]

Can you reproduce it when you try this without the "-b" flag? When I specify "-b <bundle>", I can't reproduce the problem either.

comment:4 follow-up: ↓ 5 Changed 10 years ago by solj

  • Owner changed from desai to solj
  • Status changed from new to accepted

I think https://gist.github.com/1036917 should fix the problem for you.

comment:5 in reply to: ↑ 4 Changed 10 years ago by https://profiles.google.com/holger.weiss

Replying to solj:

I think https://gist.github.com/1036917 should fix the problem for you.

This works fine if I confirm the prompt by answering "y"(es), but a "N"(o) reply must still be confirmed twice.

comment:6 Changed 10 years ago by solj

  • Status changed from accepted to closed
  • Resolution set to fixed

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.