Modify

Ticket #1077 (closed enhancement: duplicate)

Opened 10 years ago

Last modified 10 years ago

Support explicit removal and exclusion of packages

Reported by: https://www.google.com/accounts/o8/id?id=AItOawm53g_OvEixgi55cBdUXTHWrAwrQcK1PlU Owned by: https://www.google.com/accounts/o8/id?id=AItOawnSjgovXZr-_V3vGkvMSR0pc5LDykRc1Nc
Priority: major Milestone: Bcfg2 1.3.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc: jsbillin@…

Description

Currently, there is no way to explicitly remove a package from a system. You can simply not include it in the config and run with bcfg2 -r, but that doesn't catch all use cases. It'd be nice to be able to specify the package in a bundle and exclude it as a rule, much like you can do with a Path item.

Attachments

Change History

comment:1 Changed 10 years ago by https://www.google.com/accounts/o8/id?id=AItOawnSjgovXZr-_V3vGkvMSR0pc5LDykRc1Nc

  • Owner changed from desai to https://www.google.com/accounts/o8/id?id=AItOawnSjgovXZr-_V3vGkvMSR0pc5LDykRc1Nc
  • Status changed from new to accepted

comment:2 Changed 10 years ago by solj

  • Status changed from accepted to closed
  • Resolution set to duplicate

Duplicate of #824.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.