Modify

Ticket #1107 (closed defect: worksforme)

Opened 10 years ago

Last modified 8 years ago

DatabaseError in bcfg2 dynamic reporting

Reported by: https://www.google.com/accounts/o8/id?id=AItOawndHbt6oQD5o4llC_tsXLYSWsFqERWT0_Q Owned by: desai
Priority: major Milestone:
Component: bcfg2-reports Version: 1.0
Keywords: Cc:

Description

Hi,

I use the DBStats plugin for reporting. It started working fine, but now I get a database error if I click on a bad element:

DatabaseError? at /elements/bad/3574939

too many SQL variables

Request Method: GET Request URL: https://bcfg2.uni-paderborn.de/bcfg2/elements/bad/3574939 Django Version: 1.2.3 Exception Type: DatabaseError? Exception Value:

too many SQL variables

Exception Location: /usr/lib/pymodules/python2.6/django/db/backends/sqlite3/base.py in execute, line 200 Python Executable: /usr/bin/python Python Version: 2.6.6 Python Path: ['/usr/lib/python2.6', '/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk', '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload', '/usr/local/lib/python2.6/dist-packages', '/usr/lib/python2.6/dist-packages', '/usr/lib/pymodules/python2.6'] Server time: Thu, 29 Mar 2012 17:06:33 +0200

Traceback:

Environment:

Request Method: GET Request URL: https://bcfg2.uni-paderborn.de/bcfg2/elements/bad/3574939 Django Version: 1.2.3 Python Version: 2.6.6 Installed Applications: ['django.contrib.auth',

'django.contrib.contenttypes', 'django.contrib.sessions', 'django.contrib.sites', 'django.contrib.admin', 'Bcfg2.Server.Reports.reports']

Installed Middleware: ('django.middleware.common.CommonMiddleware?',

'django.contrib.sessions.middleware.SessionMiddleware?', 'django.contrib.auth.middleware.AuthenticationMiddleware?', 'django.middleware.doc.XViewMiddleware')

Traceback: File "/usr/lib/pymodules/python2.6/django/core/handlers/base.py" in get_response

  1. response = callback(request, *callback_args, callback_kwargs)

File "/usr/lib/python2.6/dist-packages/Bcfg2/Server/Reports/reports/views.py" in config_item

  1. for x in shared_entries.values('interaction')])\

File "/usr/lib/pymodules/python2.6/django/db/models/query.py" in _result_iter

  1. self._fill_cache()

File "/usr/lib/pymodules/python2.6/django/db/models/query.py" in _fill_cache

  1. self._result_cache.append(self._iter.next())

File "/usr/lib/pymodules/python2.6/django/db/models/query.py" in iterator

  1. for row in self.query.get_compiler(self.db).results_iter():

File "/usr/lib/pymodules/python2.6/django/db/models/sql/compiler.py" in results_iter

  1. for rows in self.execute_sql(MULTI):

File "/usr/lib/pymodules/python2.6/django/db/models/sql/compiler.py" in execute_sql

  1. cursor.execute(sql, params)

File "/usr/lib/pymodules/python2.6/django/db/backends/util.py" in execute

  1. return self.cursor.execute(sql, params)

File "/usr/lib/pymodules/python2.6/django/db/backends/sqlite3/base.py" in execute

  1. return Database.Cursor.execute(self, query, params)

Exception Type: DatabaseError? at /elements/bad/3574939 Exception Value: too many SQL variables

Client and server version is 1.2.2 with very few unrelated patches.

Any ideas?

Thanks,

Christopher

Attachments

Change History

comment:1 Changed 8 years ago by solj

  • Status changed from new to closed
  • Resolution set to worksforme

I cannot reproduce this with the latest stable release (and we require a more recent version of django). Please reopen if this is still an issue.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.