Modify

Ticket #1109 (closed defect: invalid)

Opened 10 years ago

Last modified 7 years ago

NotImplementedError:

Reported by: https://www.google.com/accounts/o8/id?id=AItOawm7-QeHxXGyyMwjN6_wFPC-gGTvrxu0YaE Owned by: desai
Priority: minor Milestone:
Component: bcfg2-doc Version:
Keywords: Cc:

Description

How to Reproduce

While doing a GET operation on /log/src/lib/Server/Plugins, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'mode': u'path_history',
 'path': u'/src/lib/Server/Plugins',
 'rev': u'03442c4a90f613283c8909da9175d7d05203d1bc'}

User Agent was: Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20120318 Firefox/11.0 SeaMonkey/2.8

System Information

Trac 0.11.7
Python 2.6.5 (r265:79063, Apr 16 2010, 14:15:55)
[GCC 4.4.3]
setuptools 0.6
SQLite 3.6.22
pysqlite 2.4.1
Genshi 0.5.1
mod_python 3.3.1
Pygments 1.2.2
GIT 1.7.0.4
jQuery: 1.3.2

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.6/dist-packages/trac/versioncontrol/web_ui/log.py", line 145, in process_request
    for old_path, old_rev, old_chg in history(limit+1):
  File "/usr/lib/python2.6/dist-packages/trac/versioncontrol/web_ui/log.py", line 107, in history
    for h in repos.get_path_history(path, rev, limit):
  File "/usr/lib/python2.6/dist-packages/trac/versioncontrol/cache.py", line 325, in get_path_history
    return self.repos.get_path_history(path, rev, limit)
  File "/usr/lib/python2.6/dist-packages/trac/versioncontrol/api.py", line 318, in get_path_history
    raise NotImplementedError
NotImplementedError

Attachments

Change History

comment:1 Changed 10 years ago by solj

  • Status changed from new to closed
  • Resolution set to invalid

This should probably be reported at one of the places listed at http://wiki.mcs.anl.gov/IT/index.php/Main_Page since it's not directly related to bcfg2 and I don't believe the systems people ever look at these bugs.

comment:2 Changed 7 years ago by Richardheef

  • Version 1.0 deleted
  • Milestone Bcfg2 1.3.0 Release deleted

This is entirely overdue in versions with timber and in just christian simulants with version. https://my.swu.edu/ICS/icsfs/tabfen45.html?target=87309a83-9c55-4de4-a2c7-9186e9aa2905 Key that is such.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.