Modify

Ticket #1111 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Enabling and Restarting a service is concomitant

Reported by: http://bwong114.myopenid.com/ Owned by: https://www.google.com/accounts/o8/id?id=AItOawnSjgovXZr-_V3vGkvMSR0pc5LDykRc1Nc
Priority: major Milestone: Bcfg2 1.3.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc:

Description

Given the following declaration in a bundle:

<BoundService? name="ExampleService?" type="chkconfig" status="on" mode="manual"/>

It seems that 'manual' means that no changes to the service will happen, ever.

The following situations will manifest given this meaning: When the service is set to not start at boot, no changes will be made when a bcfg2 client run is invoked. When the service is set to start at boot, no changes will be made when a bcfg2 client run is invoked.

The problem is that we have declared a state of the machine in the bundle, yet here we see that these two scenarios do not achieve an identical, final state.

This is not intuitive, because it is expected that despite what state the machines are in, the configuration management system will at least make them identical.

Attachments

Change History

comment:1 Changed 10 years ago by https://www.google.com/accounts/o8/id?id=AItOawnSjgovXZr-_V3vGkvMSR0pc5LDykRc1Nc

  • Owner changed from desai to https://www.google.com/accounts/o8/id?id=AItOawnSjgovXZr-_V3vGkvMSR0pc5LDykRc1Nc
  • Status changed from new to accepted

comment:2 Changed 10 years ago by https://www.google.com/accounts/o8/id?id=AItOawnSjgovXZr-_V3vGkvMSR0pc5LDykRc1Nc

  • Status changed from accepted to closed
  • Resolution set to fixed

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.