Modify

Ticket #186 (closed defect: fixed)

Opened 15 years ago

Last modified 15 years ago

Client Traceback

Reported by: lueningh Owned by: desai
Priority: minor Milestone: Bcfg2 0.8.5 Release
Component: bcfg2-client Version:
Keywords: Cc:

Description

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/Bcfg2/Client/Toolset.py", line 241, in InstallEntry
    self.states[entry] = method(entry)
  File "/usr/lib/python2.3/site-packages/Bcfg2/Client/Toolset.py", line 367, in InstallDirectory
    pwd.getpwnam(entry.get('owner'))[f5e4281313ff9004be488e420f90d5fe413bb5c1] (SVN r2), grp.getgrnam(entry.get('group'))[f5e4281313ff9004be488e420f90d5fe413bb5c1] (SVN r2))
TypeError: getgrnam() argument 1 must be string, not None

Attachments

Change History

comment:1 Changed 15 years ago by desai

  • Status changed from new to closed
  • Resolution set to fixed

This is caused by an unbound entry; group for this entry is not set. The new client does better checking, so this is already better behaved.

comment:2 Changed 15 years ago by desai

  • Milestone set to Bcfg2 0.8.5 Release

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.