Modify

Ticket #29 (closed defect: fixed)

Opened 14 years ago

Last modified 13 years ago

Server tracebacks

Reported by: lueningh@… Owned by: desai
Priority: major Milestone: Bcfg2 0.8.1 Release
Component: bcfg2-server Version:
Keywords: Cc:

Description

On the server 0.8.0pre7 console when a client runs:

Traceback (most recent call last):
  File "/usr/lib/python2.3/logging/handlers.py", line 408, in emit
    self.socket.send(msg)
error: (107, 'Transport endpoint is not connected')
Client tg-c001.uc.teragrid.org reported state dirty
Traceback (most recent call last):
  File "/usr/lib/python2.3/logging/handlers.py", line 408, in emit
    self.socket.send(msg)
error: (107, 'Transport endpoint is not connected')

Attachments

logging.patch (1.2 KB) - added by desai 14 years ago.

Change History

comment:1 Changed 14 years ago by lueningh@…

I see now that this isn't just when a client runs. The server is just sitting there spitting out these messages every once and a while now, perhaps when a fam event happens.

Changed 14 years ago by desai

comment:2 Changed 14 years ago by desai

  • Status changed from new to assigned
  • Milestone set to Bcfg2 0.8.1 Release

I think this is caused by syslog rotation. The attached patch should fix things.

comment:3 Changed 14 years ago by desai

  • Status changed from assigned to closed
  • Resolution set to fixed

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.