Modify

Ticket #398 (closed defect: worksforme)

Opened 15 years ago

Last modified 15 years ago

Installing a ConfigFile kills symlinks

Reported by: naapuri Owned by: desai
Priority: major Milestone:
Component: bcfg2-client Version:
Keywords: Cc:

Description

I had a ConfigFile? statement for /foo/bar/baz.conf. On the client, /foo was a symlink to /real-foo, and there the bar/ subdir didn't exist.

When installing baz.conf, the bcfg2 client killed the /foo -> /real-foo symlink and created directories /foo/ and /foo/bar/.

I expected the client not to mind that /foo/ is a symlink.

Attachments

pos.diff (1.6 KB) - added by desai 15 years ago.

Change History

Changed 15 years ago by desai

comment:1 Changed 15 years ago by desai

  • Status changed from new to assigned

I can't replicate this problem in my test environment, but this patch both cleans up the code and adds more logging to indicate why it is (re)creating paths.

comment:2 Changed 15 years ago by desai

  • Status changed from assigned to closed
  • Resolution set to worksforme

Since this isn't reproducable with the new code, I am closing this ticket for now.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.