Modify

Ticket #427 (closed defect: invalid)

Opened 15 years ago

Last modified 15 years ago

RPMng driver reads in file when verifying file size

Reported by: Axel.Thimm@… Owned by: desai
Priority: minor Milestone:
Component: bcfg2-client Version: 0.9.x
Keywords: Cc:

Description

Passing md5 alone in ticket #426 was not enough to really create a quick mode. The verification was still very slow and I checked that access time was modified on the packages' files.

After some testing I found that this was due to the file size verification and most probably due to the prelinking stuff.

But calling rpm -V --nomd5 works w/o accessing the file contents, so it must be possible to verify the filesize w/o piping the file into the (un)prelinking code. Maybe it is just a constant offset or something similar that can easily be computed.

Attachments

Change History

comment:1 Changed 15 years ago by Axel.Thimm@…

  • Status changed from new to closed
  • Resolution set to invalid

It looks like rpm is cheating, e.g. it does not read in the file, but it would have to - using rpm -V --nomd5 yields wrong sizes for the files.

bcfg2's behaviour is therefore correcter. One could argue that the proper behaviour would be to copy rpm and its bugs, but I don't think that makes really sense here.

closing as invalid, since this is not a bug of bcfg2.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.