Modify

Ticket #587 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

New service spec'ed in Bundle doesn't get started immediately

Reported by: [email protected] Owned by: desai
Priority: critical Milestone: Bcfg2 0.9.6 Release
Component: bcfg2-client Version: 0.9.x
Keywords: service bundle Cc:

Description

If I specify a service in a Bundle:

<Bundle name='syslog-ng' version='2.0'>
  <Group name='basic'>
    <ConfigFile name='/etc/syslog-ng/syslog-ng.conf'/>
    <Package name='syslog-ng'/>
    <Service name='syslog-ng'/>
  </Group>
</Bundle>

and the associated status attribute in a Svcmgr file:

... <Service name='syslog-ng' status='on'/> ...

the init script is added to rc via the chkconfig cmd but the service is not started. It only starts once I've changed run levels. I've confirmed this behavior with 0.9.5.7 on RHEL 5.1 and solj has seen it on debian as well. This is especially annoying when adding a brand new bundle/service since I cant work around it by touching a config file.

-cj

Attachments

Change History

comment:1 Changed 14 years ago by cjherman <[email protected]…>

As per Desai's suggestion, I've added the supervised attribute to the service and moved it all into a Rules/basic.xml file:

... <Service name='syslog-ng' status='on' supervised='true'/> ...

I am seeing some different, but still incorrect behaviour:

[[email protected] ~]# service syslog-ng status
syslog-ng is stopped
[[email protected] ~]# bcfg2 -v -q
Loaded tool drivers:
 Action     Chkconfig  POSIX      YUMng

Phase: initial
Correct entries:        557
Incorrect entries:      1
Total managed entries:  558
Unmanaged entries:      37

Installing Service syslog-ng
The Following Bundles have been modified:
 syslog-ng

Installing Service syslog-ng

Phase: final
Correct entries:        558
Incorrect entries:      0
Total managed entries:  558
Unmanaged entries:      37

[[email protected] ~]# service syslog-ng status
syslog-ng is stopped

comment:2 Changed 14 years ago by desai

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to Bcfg2 0.9.6 Release

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.