Modify

Ticket #650 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

PseudoFam mode doesn't work, Gamin-related traceback

Reported by: kisielk Owned by: solj
Priority: major Milestone: Bcfg2 1.0.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc:

Description

Running without gamin or FAM installed:

/usr/sbin/bcfg2-server:12: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import logging, md5, select, socket, sys, time
/usr/lib64/python2.6/site-packages/Bcfg2/Client/Tools/__init__.py:12: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  import os, popen2, stat, sys, Bcfg2.Client.XML, time
/usr/lib64/python2.6/site-packages/Bcfg2/tlslite/utils/cryptomath.py:9: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
Unexpected instantiation failure for plugin Base
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Core.py", line 85, in init_plugins
    self.plugins[plugin] = plug(self, self.datastore)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugins/Base.py", line 25, in __init__
    self.core.fam)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 187, in __init__
    fam.AddMonitor(name, self)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 190, in AddMonitor
    handle = GaminEvent(handleID, path, 'exists')
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 96, in __init__
    action_map = {GAMCreated: 'created', GAMExists: 'exists', GAMChanged: 'changed',
NameError: global name 'GAMCreated' is not defined
Unexpected instantiation failure for plugin Bundler
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Core.py", line 85, in init_plugins
    self.plugins[plugin] = plug(self, self.datastore)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugins/Bundler.py", line 19, in __init__
    Bcfg2.Server.Plugin.XMLDirectoryBacked.__init__(self, self.data, self.core.fam)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 187, in __init__
    fam.AddMonitor(name, self)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 190, in AddMonitor
    handle = GaminEvent(handleID, path, 'exists')
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 96, in __init__
    action_map = {GAMCreated: 'created', GAMExists: 'exists', GAMChanged: 'changed',
NameError: global name 'GAMCreated' is not defined
Unexpected instantiation failure for plugin Cfg
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Core.py", line 85, in init_plugins
    self.plugins[plugin] = plug(self, self.datastore)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 675, in __init__
    self.AddDirectoryMonitor('')
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 723, in AddDirectoryMonitor
    reqid = self.core.fam.AddMonitor(name, self)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 190, in AddMonitor
    handle = GaminEvent(handleID, path, 'exists')
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 96, in __init__
    action_map = {GAMCreated: 'created', GAMExists: 'exists', GAMChanged: 'changed',
NameError: global name 'GAMCreated' is not defined
Failed to instantiate plugin Metadata
Unexpected instantiation failure for plugin Pkgmgr
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Core.py", line 85, in init_plugins
    self.plugins[plugin] = plug(self, self.datastore)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 411, in __init__
    XMLDirectoryBacked.__init__(self, self.data, self.core.fam)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 187, in __init__
    fam.AddMonitor(name, self)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 190, in AddMonitor
    handle = GaminEvent(handleID, path, 'exists')
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 96, in __init__
    action_map = {GAMCreated: 'created', GAMExists: 'exists', GAMChanged: 'changed',
NameError: global name 'GAMCreated' is not defined
Unexpected instantiation failure for plugin Rules
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Core.py", line 85, in init_plugins
    self.plugins[plugin] = plug(self, self.datastore)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 411, in __init__
    XMLDirectoryBacked.__init__(self, self.data, self.core.fam)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 187, in __init__
    fam.AddMonitor(name, self)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 190, in AddMonitor
    handle = GaminEvent(handleID, path, 'exists')
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 96, in __init__
    action_map = {GAMCreated: 'created', GAMExists: 'exists', GAMChanged: 'changed',
NameError: global name 'GAMCreated' is not defined
Unexpected instantiation failure for plugin SSHbase
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Core.py", line 85, in init_plugins
    self.plugins[plugin] = plug(self, self.datastore)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugins/SSHbase.py", line 49, in __init__
    self.core.fam)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/Plugin.py", line 187, in __init__
    fam.AddMonitor(name, self)
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 190, in AddMonitor
    handle = GaminEvent(handleID, path, 'exists')
  File "/usr/lib64/python2.6/site-packages/Bcfg2/Server/FileMonitor.py", line 96, in __init__
    action_map = {GAMCreated: 'created', GAMExists: 'exists', GAMChanged: 'changed',
NameError: global name 'GAMCreated' is not defined
Fatal error: No Metadata Plugin

It seems the problem is that the PseudoFam? class instantiates a GaminEvent?, which requires a bunch of stuff imported from the gamin module.

Attachments

Change History

comment:1 Changed 12 years ago by solj

  • Owner changed from desai to solj
  • Status changed from new to assigned

comment:2 Changed 12 years ago by solj

  • Status changed from assigned to closed
  • Resolution set to fixed

This should be resolved in [6ec4573ccd6f67234b81a8aa9a6dc1ca024a21d6] (SVN r5234).

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.