Modify

Ticket #717 (closed defect: worksforme)

Opened 12 years ago

Last modified 12 years ago

Installing with the Packages plugin "succeeds" when Yum can't find the package

Reported by: David Strauss <david@…> Owned by: desai
Priority: critical Milestone: Bcfg2 1.0.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc:

Description

If a repository is specified in Packages/config.xml but not in /etc/yum.repos.d/*, bcfg2 attempts to install the package, reports "success," but the package remains not installed.

(On a minor note, the message reporting success misspells "succeeded.")

Attachments

Change History

comment:1 Changed 12 years ago by David Strauss <david@…>

Yum seems to return zero when an invalid package is specified. Yum considers a zero return value to mean something akin to "operating as designed."

comment:2 in reply to: ↑ description Changed 12 years ago by solj

  • Status changed from new to closed
  • Resolution set to fixed

Replying to David Strauss <david@…>:

(On a minor note, the message reporting success misspells "succeeded.")

Fixed this issue in [78aa59d824454beacf68e3fc6914b39153372cc4] (SVN r5431).

comment:3 Changed 12 years ago by solj

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:4 Changed 12 years ago by desai

  • Status changed from reopened to closed
  • Resolution set to worksforme

Yeah, this is an "interesting" behavior based on yum operating as intended. Lord knows what it means when it returns rc != 0. The intermediate success reported is largely a cosmetic issue. We pull up to date information about the database after each package tool execution pass, so the client should detect the current state properly regardless of this behavior.

If the client doesn't report the correct state for any package entries, open a new ticket on that. That behavior would definitely be a bug.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.