Modify

Ticket #79 (closed defect: fixed)

Opened 15 years ago

Last modified 15 years ago

Traceback

Reported by: leggett Owned by: anonymous
Priority: major Milestone:
Component: bcfg2-client Version:
Keywords: Cc:

Description

Failure in VerifyEntry? Traceback (most recent call last):

File "/usr/lib/python2.3/site-packages/Bcfg2/Client/Toolset.py", line 221, in VerifyEntry?

self.states[entry] = method(entry)

File "/usr/lib/python2.3/site-packages/Bcfg2/Client/Toolset.py", line 381, in VerifyConfigFile?

diff = '\n'.join([x for x in difflib.unified_diff(content.split('\n'), tempdata.split('\n'))])

AttributeError?: 'NoneType?' object has no attribute 'split' Entry: <ConfigFile? name="/var/globus/var/lib/perl/Grid/GPT/LocalEnv.pm" perms="0 000" current_owner="root" current_group="root" current_perms="0644"/> /usr/lib/python2.3/site-packages/Bcfg2/Client/Toolset.py:158: FutureWarning?: %u/%o/%x/%X of negative int will return a signed string in Python 2.4 and up

print "State verify evidently failed for %s" % (msg)

State verify evidently failed for <Element ConfigFile? at b7b70e30>

Not sure why this happens yet, but it's a traceback and you said you wanted them all.

Attachments

Change History

comment:1 Changed 15 years ago by desai

  • Owner changed from desai to anonymous
  • Status changed from new to assigned

It looks like the ConfigFile? entry came over the wire unbound (no contents, perms, etc)

Do you get a failed to bind entry ConfigFile? <path> on the server? If so, that gives me a good idea how to fix this.

comment:2 Changed 15 years ago by desai

  • Status changed from assigned to closed
  • Resolution set to fixed

I am pretty sure this is fixed in [266e94c5f85b68eaeb8d546d97244f2b88272842] (SVN r1989). You were hitting an error path caused by entry bind failure (the perms='0000' in the traceback is imporant bit of info).

The code will now return a verification failure and produce an error message.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.