Modify

Ticket #8 (closed defect: fixed)

Opened 14 years ago

Last modified 13 years ago

Directory Installation Failure

Reported by: leggett@… Owned by: desai
Priority: major Milestone: Bcfg2 0.8.1 Release
Component: bcfg2-client Version:
Keywords: Cc: leggett@…

Description (last modified by desai) (diff)

There seems to be a bug in the directory analysis. Here's two examples:

[root@nmpdr-anno-1:/fc/gpfs-2.3.0-10]$ /usr/sbin/bcfg2 -q -n
...
Redhat[dryrun]: Entries to update:
...
Redhat[dryrun]: Directory: /disks/gpfs1
...

[root@nmpdr-anno-1:/fc/gpfs-2.3.0-10]$ ls -ld /disks/
drwxr-xr-x  3 root root 4096 Dec  5 16:08 /disks/

[root@nmpdr-anno-1:/fc/gpfs-2.3.0-10]$ ls -ld /disks/gpfs1/
drwxr-xr-x  2 root root 16384 Dec  5 16:10 /disks/gpfs1/

And here's one more:

[leggett@ci-www:/var/db/bcfg]$ sudo /usr/sbin/bcfg2 -q -n
...
Redhat[dryrun]: Directory: /var/www/localhost/cgi-bin
Redhat[dryrun]: Directory: /var/www/localhost/htdocs
...

[leggett@ci-www:/var/db/bcfg]$ ls -ld /var
drwxr-xr-x  22 root root 4096 Jan 16 15:01 /var/

[leggett@ci-www:/var/db/bcfg]$ ls -ld /var/www
lrwxrwxrwx  1 root root 17 Jan 16 15:01 /var/www -> /disks/space0/www/

[leggett@ci-www:/var/db/bcfg]$ ls -ld /disks/space0/www
drwxr-xr-x  15 root root 4096 Jan 19 08:07 /disks/space0/www/

[leggett@ci-www:/var/db/bcfg]$ ls -ld /disks/space0/www/localhost
drwxr-xr-x  14 root root 4096 Jan 31 08:29 /disks/space0/www/localhost/

[leggett@ci-www:/var/db/bcfg]$ ls -ld /disks/space0/www/localhost/htdocs
drwxrwxr-x  11 root admins 4096 Jan 25 22:59 /disks/space0/www/localhost/htdocs/

[leggett@ci-www:/var/db/bcfg]$ ls -ld /disks/space0/www/localhost/cgi-bin
drwxr-xr-x  2 root root 4096 Jan 20 14:22 /disks/space0/www/localhost/cgi-bin/

The last one actually causes problems because it creates /var/www/localhost but removes the /var/www symlink to make it an actual directory which ain't good.

Attachments

Change History

comment:1 Changed 14 years ago by desai

  • Milestone set to Bcfg2 0.8.1 Release

comment:2 Changed 14 years ago by leggett@…

The GPFS directory was caused by inconsistent permissions in the bundle and the filesystem, so that was a false alarm. I'm still not sure of the /var/www/localhost one though.

comment:3 Changed 14 years ago by desai

  • Status changed from new to assigned

comment:4 Changed 14 years ago by desai

  • Description modified (diff)

comment:5 Changed 14 years ago by desai

Can you try running this with a -d (to get operation debugging information)

comment:6 Changed 14 years ago by desai

  • Summary changed from Bug with directory analysis to Directory Installation Failure

comment:7 Changed 14 years ago by desai

  • Cc leggett@… added

one more try to see if email notification is working

comment:8 Changed 14 years ago by desai

  • Status changed from assigned to closed
  • Resolution set to fixed

We have tracked this to a bug in config file installation. If a component of a parent path was a symlink, it would get clobbered. This is fixed in [6b7fe3dffd69efeeeabbce0bcd6cab97bde94cef] (SVN r1743)

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.