Modify

Ticket #801 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Packages plugin doesn't initialize properly

Reported by: strauss Owned by: desai
Priority: major Milestone: Bcfg2 1.1.0 Release
Component: bcfg2-server Version: 1.0
Keywords: Cc: solj@…

Description

Steps to reproduce:

  • Install bcfg2-server
  • Enable and configure the Packages plugin's config.xml file.
  • Restart bcfg2-server
  • Run bcfg2-admin xcmd Packages.Refresh

You get a backtrace:

Traceback (most recent call last):
  File "/usr/sbin/bcfg2-admin", line 78, in ?
    main()
  File "/usr/sbin/bcfg2-admin", line 70, in main
    mode(args[1:])
  File "/usr/lib/python2.4/site-packages/Bcfg2/Server/Admin/Xcmd.py", line 42, in __call__
    data = apply(getattr(proxy, cmd), args)
  File "/usr/lib/python2.4/site-packages/Bcfg2/Proxy.py", line 79, in __call__
    raise xmlrpclib.Fault(20, "Server Failure")
xmlrpclib.Fault: <Fault 20: 'Server Failure'>

Workaround (after the steps to reproduce above):

  • Remove all files from /var/lib/bcfg2/Packages/cache/
  • Run bcfg2-admin xcmd Packages.Refresh again.
  • Should see "True" as the response.

This has been verified on Ubuntu 8.04 and RHEL 5.

Attachments

Change History

comment:1 Changed 12 years ago by strauss

  • Component changed from bcfg2-client to bcfg2-server

comment:2 Changed 12 years ago by solj

  • Cc solj@… added

Weird, I can't reproduce the error on lucid. I'm guessing this may have something to do with the server-side failure. Do you see any backtraces there?

comment:3 Changed 12 years ago by solj

  • Milestone changed from Bcfg2 1.0.1 Release to Bcfg2 1.1.0 Release

comment:4 Changed 12 years ago by desai

  • Status changed from new to closed
  • Resolution set to fixed

I'm pretty sure this is fixed by some code improvements I just checked in [4b84fa15c231c5ad72d261fdb27c470a386de4b3] (SVN r5722). Please re-ping if you see this again.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.