Modify

Ticket #812 (closed defect: invalid)

Opened 12 years ago

Last modified 12 years ago

BoundPackage version=foo-bar instead of version=foo release=bar

Reported by: https://www.google.com/accounts/o8/id?id=AItOawkSsFd6lqQkgZsyjbW-povvFQdV1OAQFVw Owned by: desai
Priority: minor Milestone: Bcfg2 1.0.1 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc:

Description

a BoundPackage? with attributes version=foo release=bar will cause a ValueError?:

File "/usr/lib/python2.4/site-packages/Bcfg2/Client/Tools/RPMng.py", line 209, in VerifyPackage?

version, release = entry.get('version').split('-')

ValueError?: need more than 1 value to unpack

See attached patch

Attachments

RPMng.py-attr-ver-rel.patch (641 bytes) - added by https://www.google.com/accounts/o8/id?id=AItOawkSsFd6lqQkgZsyjbW-povvFQdV1OAQFVw 12 years ago.
patch to accept version= release= and just version=

Change History

Changed 12 years ago by https://www.google.com/accounts/o8/id?id=AItOawkSsFd6lqQkgZsyjbW-povvFQdV1OAQFVw

patch to accept version= release= and just version=

comment:1 Changed 12 years ago by https://www.google.com/accounts/o8/id?id=AItOawkSsFd6lqQkgZsyjbW-povvFQdV1OAQFVw

This is not a bug.

This was an error in my config. I am using new-style Pkgmgr definitions and did not define an instance of the Package.

<BoundPackage? name="foo" version="a" release="b" type="yum" arch="x86_64">

was what I had. now I ahve

<BoundPackage? name="foo" type="yum"> <Instance ... </BoundPackage?>

Sorry for the noise

comment:2 Changed 12 years ago by solj

  • Status changed from new to closed
  • Resolution set to invalid

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.