Modify

Ticket #913 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Packages/YUMng confused with or/alternate/provide dependencies

Reported by: m4z <[email protected]…> Owned by: desai
Priority: major Milestone: Bcfg2 1.2.0 Release
Component: bcfg2-server Version: 1.0
Keywords: Cc:

Description

This seems to be very similar to #822, but with YUMng (in 1.0.1).

On a system that is fine as far as yum or "zypper verify" is concerned, bcfg would like me to install a package:

chaos:~ # bcfg2 -nqv
Running probe groups
Probe groups has result:
group:x86_64
/usr/local/lib/python2.6/site-packages/Bcfg2/Client/Tools/rpmtools.py:24: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Loaded tool drivers:
 Action     Chkconfig  POSIX      YUMng     
WARNING: Package foo 1.2-28_11.3.x86_64 requires GPG Public key with ID bar
         Disabling signature check.

Phase: initial
Correct entries:        401
Incorrect entries:      1
Total managed entries:  402
Unmanaged entries:      1

In dryrun mode: suppressing entry installation for:
 Package:yast2-gtk 

Phase: final
Correct entries:        401
Incorrect entries:      1
 Package:yast2-gtk 
Total managed entries:  402
Unmanaged entries:      1

chaos:~ # 

The only clue why it could want to do this is this:

chaos:~ # for i in $(rpm -qa); do yum deplist $i | grep -B100 yast2-gtk | grep "^package:" | tail -3; done
package: yast2.x86_64 2.19.13-1.7
package: yast2-packager.x86_64 2.19.7-1.5
chaos:~ # 

But for every provider group of these dependencies, there is already one provider installed:

# yum deplist yast2 yast2-packager
Finding dependencies:
package: yast2.x86_64 2.19.13-1.7
[...]
  dependency: yast2_ui
   provider: yast2-gtk.x86_64 2.21.58-2.2               <- bcfg2 wants this (whatever version)
   provider: yast2-qt.x86_64 2.19.1-1.9
   provider: yast2-ncurses.x86_64 2.19.5-1.6            <- this is installed
   provider: yast2-gtk.x86_64 2.21.68-0.1.1
[...]
package: yast2.x86_64 2.19.13-1.7
[...]
  dependency: yast2_ui
   provider: yast2-gtk.x86_64 2.21.58-2.2
   provider: yast2-qt.x86_64 2.19.1-1.9
   provider: yast2-ncurses.x86_64 2.19.5-1.6            <- this is installed
   provider: yast2-gtk.x86_64 2.21.68-0.1.1
[...]
  dependency: yast2_ui_pkg
   provider: yast2-ncurses-pkg.x86_64 2.19.3-1.4        <- this is installed
   provider: yast2-qt-pkg.x86_64 2.19.2-1.10
   provider: yast2-gtk.x86_64 2.21.58-2.2
   provider: yast2-gtk.x86_64 2.21.68-0.1.1

Attachments

Change History

comment:1 Changed 12 years ago by m4z <[email protected]…>

  • Component changed from bcfg2-client to bcfg2-server

I can't yet pinpoint the cause, but I'm having a similar problem on openSUSE11.2 (the above was openSUSE11.3).

foo:~ # bcfg2 -enqv
Running probe groups
Probe groups has result:
group:suse
group:openSUSE
group:openSUSE11.2
group:x86_64
/usr/lib/python2.6/site-packages/Bcfg2/Client/Tools/rpmtools.py:24: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Loaded tool drivers:
 Action     Chkconfig  POSIX      YUMng
WARNING: Package ... requires GPG Public key with ID ...
         Disabling signature check.

Phase: initial
Correct entries:        389
Incorrect entries:      2
Total managed entries:  391
Unmanaged entries:      0

In dryrun mode: suppressing entry installation for:
 Package:glib2-branding-upstream  Package:gpg2-lang

Phase: final
Correct entries:        389
Incorrect entries:      2
 Package:glib2-branding-upstream  Package:gpg2-lang
Total managed entries:  391
Unmanaged entries:      0

foo:~ # 

Again, providers are installed for both.

Finding dependencies:
package: gpg2.x86_64 2.0.12-2.3
[...]
  dependency: gpg2-lang = 2.0.12
   provider: bundle-lang-common-ar.noarch 11.2-20.21.3
   [...]
   provider: bundle-lang-common-en.noarch 11.2-20.21.3 <- installed
   provider: gpg2-lang.noarch 2.0.12-2.3
   provider: gpg2-lang.noarch 2.0.12-2.4.1
[...]
  dependency: glib2-branding
   provider: glib2-branding-upstream.i586 2.22.1-2.2
   provider: glib2-branding-openSUSE.noarch 2.16-50.2 <- installed
   provider: glib2-branding-upstream.x86_64 2.22.1-2.2
   provider: glib2-branding-upstream.x86_64 2.22.4-0.1.1
   provider: glib2-branding-upstream.i586 2.22.4-0.1.1
[...]

I still don't understand enough of Packages.py to explain this.

comment:2 Changed 12 years ago by m4z <[email protected]…>

This problem is fixed in r6048, but a might-be-related issue (#938) does still exist or came into existence since.

I can't close this ticket. Please close it. (;

comment:3 Changed 12 years ago by desai

  • Status changed from new to closed
  • Resolution set to fixed

As requested.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.