Modify

Ticket #916 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

r6010 breaks client

Reported by: https://www.google.com/accounts/o8/id?id=AItOawmAKncTPlNx89GjuQyu9LtzyN37kpWeSCw Owned by: desai
Priority: blocker Milestone: Bcfg2 1.1.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc: [email protected]

Description

after upgrading from r5992 to r6019, the client exists with

Unknown failure
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/Bcfg2/Proxy.py", line 57, in __call__
    return _Method.__call__(self, *args)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib/pymodules/python2.6/Bcfg2/Proxy.py", line 266, in request
    self.send_content(h, request_body)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1349, in send_content
    connection.endheaders()
  File "/usr/lib/python2.6/httplib.py", line 904, in endheaders
    self._send_output()
  File "/usr/lib/python2.6/httplib.py", line 776, in _send_output
    self.send(msg)
  File "/usr/lib/python2.6/httplib.py", line 735, in send
    self.connect()
  File "/usr/lib/pymodules/python2.6/Bcfg2/Proxy.py", line 153, in connect
    self._connect_py26ssl()
  File "/usr/lib/pymodules/python2.6/Bcfg2/Proxy.py", line 188, in _connect_py26ssl
    self.sock.connect((self.host, self.port))
  File "/usr/lib/python2.6/ssl.py", line 307, in connect
    self.ca_certs)
TypeError: sslwrap() argument 3 must be string or None, not bool
Failed to download probes from bcfg2
Server Failure

This is caused by the keyfile argument to SSLSocket() on line 186 of Proxy.py being False instead of None when no client certificates are used.

Reverting r6010 fixes the problem.

Attachments

Change History

comment:1 Changed 12 years ago by solj

  • Status changed from new to closed
  • Resolution set to fixed

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.