Modify

Ticket #933 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

Can't start bcfg2 server straight from deb package

Reported by: https://www.google.com/accounts/o8/id?id=AItOawmI6G1O8nnv_Kswnf7ySzbfDBStml9oZq0 Owned by: desai
Priority: major Milestone: Bcfg2 1.2.0 Release
Component: bcfg2-client Version: 1.0
Keywords: README clients.xml. Cc:

Description

Am trying to learn bcfg2 - so downloaded bcfg2 + bcfg2-server from PPA for karmic. Server refused to start without issuing error:

No Metadata Plugin loaded; failed to instantiate Core No Metadata Plugin exiting

Was unable to find any further debugging output. After running server with 'strace' found that '/var/lib/bcfg2/Metadata/clients.xml' was non-existant. That's my fault, as that is a required component.

However, the problem I have is that the error message returned from server was useless in debugging issue. Further, there was no README included with debian package to explain minimal setup required once the package was installed.

Please add more verbose output (the above was found while running server with '-vd'), please be specific with what the error that occurred, not just 'it didn't work'. And please add a README with minimal steps required. If nothing else you can have the README simply include a link to the QuickStart? pages on this wiki.

Attachments

Change History

comment:1 Changed 11 years ago by solj

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #786. We will address this in 1.2.0.

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.