Modify

Ticket #983 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Build Failing For osx Package

Reported by: rcuza Owned by: rcuza
Priority: minor Milestone: Bcfg2 1.2.0 Release
Component: bcfg2-client Version: 1.0
Keywords: Cc:

Description

While trying to build the bcfg2 package for OS X I ran into the following error:

chown: $PATH/$FILE: Operation not permitted

A workaround is to run make as root (sudo make), but this is not desirable if it can be avoided.


To reproduce this error run the following:

$ git clone git://git.mcs.anl.gov/bcfg2.git
$ git checkout v1.1.1
$ make

More detailed snippet of error log:

running install_egg_info
Writing osx/bcfg2pkg/Library/Python/2.6/site-packages/Bcfg2-1.1.1-py2.6.egg-info
/usr/sbin/chown -R root:admin "bcfg2pkg"
chown: bcfg2pkg/Library/Frameworks/Python.framework/Versions/Current/share/bcfg2/Hostbase/repo/batchadd.tmpl: Operation not permitted
chown: bcfg2pkg/Library/Frameworks/Python.framework/Versions/Current/share/bcfg2/Hostbase/repo/dhcpd.conf.head: Operation not permitted
chown: bcfg2pkg/Library/Frameworks/Python.framework/Versions/Current/share/bcfg2/Hostbase/repo/dhcpd.tmpl: Operation not permitted

I've attached the full output of make to this ticket.

Attachments

osx_make_error.txt (59.1 KB) - added by rcuza 12 years ago.

Change History

Changed 12 years ago by rcuza

comment:1 Changed 12 years ago by rcuza

This was done on 10.6.6. Python is version 2.6.1.

comment:2 Changed 12 years ago by rcuza

  • Owner changed from desai to rcuza
  • Status changed from new to assigned

After talking to solj on irc I have a better sense of why the chown is in the Makefile.

Ownership and access permissions: The files that the Installer application places on the target computer have the same ownership and access permissions of the payload’s files. Therefore, you must set up the owner and access permissions of component files appropriately before building the installation package; otherwise, users may have difficulty manipulating those files after they are installed or Installer may be unable to copy payloads to

Commenting the one chown line out allows the Make to proceed as expected.

comment:3 Changed 12 years ago by rcuza

  • Status changed from assigned to closed
  • Resolution set to fixed

This no longer seems to be a problem on Mac OS X 10.6.6 with PackageMaker? 3.0.2.

Commit 5096c67da3cee8f35733c6ef6b88f5ce55b4d34b removes the chown line. Server and client packages were produced and installed on a test machine with expected results, all files owned by root:admin.

Marking bug as fixed.

comment:4 Changed 11 years ago by solj

  • Milestone changed from Bcfg2 1.1.2 Release (Bugfix) to Bcfg2 1.2.0 Release

WARNING! You need to establish a session before you can create or edit tickets. Otherwise the ticket will get treated as spam.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.