Version 11 (modified by desai, 17 years ago) (diff)


Frequently Asked Questions


  • bcfg2-repo-validate is unable to process bundle.xsd
    You will need to upgrade your libxml2 to version 2.6.23 or higher. The version shipped with many distributions is too old.
    bcfg2-0.8.1/schemas/bundle.xsd:27: element complexType: 
    Schemas parser error : CT local: The content model is not determinist.
    WXS schema bcfg2-0.8.1/schemas/bundle.xsd failed to compile
  • what pre-requisites are needed to run Bcfg2
    • libxml2 >= 2.6.23
    • lxml 0.8
    • pyopenssl ( server only )
  • what architectures does Bcfg2 support
    • Linux rpm based distros
    • Linux deb based distros
    • Solaris pkg based