Changes between Version 1 and Version 2 of ReleaseAnnouncement/1.3.0


Ignore:
Timestamp:
03/15/13 09:31:03 (9 years ago)
Author:
https://www.google.com/accounts/o8/id?id=AItOawnSjgovXZr-_V3vGkvMSR0pc5LDykRc1Nc
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • ReleaseAnnouncement/1.3.0

    v1 v2  
    88The following are major, backwards-incompatible user-facing changes: 
    99 
    10   * Reworked service modes to make them more consistent and granular. A tool located at `tools/upgrade/1.3/service_modes.py` can assist in migrating your old configurations. Due to this change, a Bcfg2 1.3 server will work with Bcfg2 1.2 (and earlier) clients with the !ServiceCompat plugin enabled, but a Bcfg2 1.2 (or earlier) server will not work with Bcfg2 1.3 clients. (http://docs.bcfg2.org/dev/server/plugins/generators/rules.html#service-mode-specification) 
     10  * Reworked service modes to make them more consistent and granular. A tool located at `tools/upgrade/1.3/service_modes.py` can assist in migrating your old configurations. Due to this change, a Bcfg2 1.3 server will work with Bcfg2 1.2 (and earlier) clients with the !ServiceCompat plugin enabled, but a Bcfg2 1.2 (or earlier) server will not work with Bcfg2 1.3 clients. Additionally, services that aren't really services -- i.e., for which the `status` command is expected to fail (or the equivalent on your OS of choice) -- are not currently supported.  That will be fixed in the next release of 1.3.  (http://docs.bcfg2.org/dev/server/plugins/generators/rules.html#service-mode-specification) 
    1111  * Moved configuration for several plugins (Rules, Packages) into base bcfg2.conf file. Reworked database configuration for DBStats to make it more accessible to other plugins. A tool located at `tools/upgrade/1.3/migrate_configs.py` can assist in migrating your old configurations. 
    1212  * Changed the 'perms' POSIX attribute to 'mode' for better consistency. A tool located at `tools/upgrade/1.3/perms_to_mode.py` can assist you in migrating your old configurations. Due to this change, you will need to enable the POSIXCompat plugin to allow older clients to talk to a 1.3 server.